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CodySoft® Templates 
Reference and User Guide 

Your CodySoft®’s Collateral Management Module® (CM) license includes access to the annually 
provided Cody ANOC and EOC pre-programmed templates. Use this guide as a reference when 
working with these templates. For guidance on working in CM, please see the CodySoft®’s 
Collateral Management Module® User Guide in the CodySoft® Help Portal’s Knowledge Base. If 
you have questions, please contact your CodySoft® administrator. 
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1 Evergreen Templates 

Created using the CMS ANOC and EOC models, the CodySoft® templates are Collateral Management 
Module® (CM) tools designed and programmed for PBP-specific versioning. 

The templates contain variable content and CMS instructions that are maintained within rules syntax. 
Keeping the CMS model content within the templates allows for yearly use. Because of this, we refer to 
the Cody templates as evergreen, which means they can be reused each year.  

Note: This section discusses the role of rules within the templates. For more information about rule 
types and rules grids, see the Rules section. 

1.1 Updating templates for CMS model changes 

Each year following CMS release of the next plan year’s ANOC and EOC model documents, Cody releases 
the evergreen templates with the year-to-year model changes. To maintain your templates as 
evergreen, Cody will also provide comparison documents showing where the model documents have 
changed since the previous year’s release. In addition, the data sources used with the Cody templates 
are also updated, as needed. 

After CMS release of its ANOC and EOC model corrections memo, Cody will provide guidance, as 
needed, on how the corrections impact template programming, such as new rules. 

1.2 Year references 

With a few exceptions, all years appear as variable using the Benefits Data Grid’s Plan_Year field with 
the TY (this year) and NY (next year) variants. This means the templates include only a few instances 
where you may need to update the year (e.g., in the EOC chapter 4 Medical Benefits chart if a PBP uses 
the current year Medicare-defined cost share amounts for Inpatient and/or SNF cost sharing).  
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1.3 CMS model instructions 

The CMS model instructions are maintained within the templates’ instruction rules. To keep the 
templates evergreen, do NOT remove the instructions. Because the instructions are placed within rules, 
they will not appear within versions, unless you want them to. To make instructions visible within 
versions, insert an x for the rule within the CustomRG rules grid. In the example below, the instruction 
will not appear within the PBP 001 version because the CustomRG rules grid does not have an x for the 
plan in the instruction rule’s cell. 

[[IF:RuleId={CustomRGinstruction}]][Plans that meet the 5% alternative language 
threshold insert:] [[ENDIF:RuleId={CustomRGinstruction}]]   

 

1.4 Omitting content 

The omit rule allows you to exclude specific content from all versions without having to create a new 
rule for it. Use of this rule helps keep the templates evergreen; that is, the content enclosed within the 
omit rule’s IF/ENDIF statements will remain in the template for potential future use.  

For example, CMS permits the editing and/or removal of some model language (e.g., per the CMS 
ANOC-EOC model instructions for HMO-POS plans). The omit rule is found on the CustomRG rules grid. 
See CustomRG rules section for more information. 

 

1.5 Variable content 

Variable content is maintained within rules. Variable content may appear embedded within rules that 
point to a rules grid, or they may be in the form of a data attribute (aka field) that pulls in content from 
a data asset such as the Benefits Data Grid.  

To keep the templates evergreen, Cody strongly recommends that users do NOT remove the variable 
content. 



CodySoft® Templates Reference and User Guide| 5 

© 2024 Cody Consulting Group, Inc.  All Rights Reserved. For internal use only. CONFIDENTIAL 

In the example below, the ANOC template contains the providerschg and noproviderschg rules for the 
variability between plans that either do have or do not have changes in its provider network. Per the 
AERG excerpt below, the H1234-001 version will include the providerschg content and the H1234-002 
version will include the noproviderschg content. 

 

AERG: 
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2 Rules 

2.1 Overview 

The Cody templates are pre-programmed with rules strings (also known as tags or rules syntax) that are 
mapped to data assets (such as the Benefits Data Grid and MBCRG Rules Grid). These assets are Excel 
spreadsheets that are uploaded to the CodySoft® Collateral Management Module® (CM) Assets Library. 

Rules strings inform CM when to have variable content appear in a version (i.e., the rule has an x for a 
specific Plan Benefit Package (PBP) within the rules grid) or where to pull content from (.e.g., the 
Benefits Data Grid; the Companion File). 

Note: Rules syntax within the Cody templates do not contain spaces. Please reference the Collateral 
Management® User Guide for instructions on how to add and create rules. 

2.2 Data Grid (DG) rule 

The Data Grid (DG) rule is a template rule that points to fields (aka attributes) within the Benefits Data 
Grid. The rules syntax for data grid fields appears as red within the templates; content pulled from the 
data grid also appears as red within the versions.  

Example of a Benefits Data Grid rules string: [[RuleId={DG}(SNF_IN<NY>)]] 

Elements within the double square brackets ([[ and ]]) of the rules string: 

RuleId={DG} identifies the data asset (DG) for the Benefits Data Grid. 

SNF_IN is the field (aka attribute) for in-network cost sharing for Skilled Nursing Facility stays. This 
field appears within Column C of the Benefits Data Grid.  

<NY> is the variant that tells CM to pull content from the grid’s next year (NY) column when parsing 
the version. TY is this year (for ANOCs only) and NY is next year. 

 
 

2.3 Rules Grid rules 

Rules Grid rules are data asset rules that point to cells within one of several rules grids. For these rules, 
CM checks whether the rule is applicable to the PBP. That is, if the rule has an x on the rules grid, the 
rule is applicable and the variable content (green; or, red if a data grid attribute) will appear within the 
version. Think of these rules as light switches to turn on (x) or off (no x). 

The rules string structure for all rules grid rules includes an IF statement (before the variable content) 
and an ENDIF statement (after the variable content).  
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The Cody templates include rules strings for three standard rules grids: 

2.3.1 AERG rules  
Variable content within the CMS models that cannot be identified via the plan bids’ PBP Reports appear 
within the template’s AERG rules IF/ENDIF statements. These rules start with the prefix “AERG” and 
point to the ANOC/EOC Rules Grid (AERG) which is auto-generated from within the AERG Wizard 
interface. In the example below, the altlanguage rule is applicable for H1234-001 as its column includes 
the lower case x. This plan’s version will include the sentence within the altlanguage rule’s IF/ENDIF 
statement. 

Example: Which PBPs will include content for the availability of the ANOC and EOC in other 
languages (5% threshold and/or business decision)? 

[[IF:RuleId={AERGaltlanguage}]]This document is available for free in 
[[RuleId={DG}(altlanguages<NY>)]]. [[ENDIF:RuleId={AERGaltlanguage}]] 

AERG: 

 

2.3.2 MBCRG rules  
Variable content within the CMS models that can be identified via the plan bids’ PBP Reports appear 
within the template’s MBCRG rules IF/ENDIF statements. These rules start with the prefix “MBCRG” 
and point to the Medical Benefits Rules Grid (MBCRG). The CodySoft® Plan Benefit Package (PBP) 
Module® auto-generates this Rules Grid Export by systematically checking the PBP Reports and the 
Benefits Data Grid.  

The MBCRG includes different rule types. Rules with the chg prefix are programmed using cell 
output from the Benefits Data Grid fields to identify year-to-year benefits changes. These chg rules 
appear in the ANOC template’s Medical Benefits Changes chart. Rules with the json prefix are 
programmed using the uploaded plan bids’ PBP Reports to primarily identify covered benefits. These 
rules appear predominantly on the EOC template’s Medical Benefits chart. In the example below, 
the system searched the H1234-001 plan’s PBP Report to identify that service category Additional 
Cardiac Rehabilitation Services (3-1) is covered as a mandatory supplemental benefit. The system 
populates the PBP’s cell for the jsonCardiacSupcardiac rule with a lower case x. 

Example: All plan types except PDP: Which PBPs cover additional cardiac rehabilitation services 
(3-1) as a mandatory supplemental benefit for next year? 

[[IF:RuleId={MBCRGjsonCardiacSupcardiac}]][[RuleId={DG}(Cardiac_addl_IN<NY>)]] 
for additional cardiac rehabilitation services 
visits.[[ENDIF:RuleId={MBCRGjsonCardiacSupcardiac}]] 
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MBCRG: 

 

MBCRGjson out-of-network rules for EOC templates with POS medical benefits charts: 

Within the DSNP and HMO EOC templates, there are two Medical Benefits charts: one with a one 
column format for in-network only cost sharing (nonPOS) and one with a two-column format for in- and 
out-of-network (POS) cost sharing. The two-column POS chart includes MBCRGjson rules that address 
out-of-network coverage and cost sharing. 

CMS PBP software: 

For this HMO-POS plan example, the Home and Bathroom Safety Devices and Modifications (14c8) 
benefit is covered as a mandatory supplemental benefit both in- and out-of-network. 

 

PBP Report (Excel format): 

 

MBCRG grid: 

The Cody MBCRG rules grid is auto-generated within the PBP Module®. For json rules, the programming 
looks to the uploaded PBP Reports to determine if a benefit is covered by a particular plan and whether 
it is covered out-of-network. If covered, an x is inserted into the cell of the applicable PBP’s column for 
the rule(s). 

For the Home and Bathroom Safety Devices and Modifications (14c8) benefit example above, the benefit 
is covered as a mandatory supplemental benefit both in- and out-of-network. Within the MBCRG, x’s 
have been inserted for the covered benefit rule (jsonBathroomSD) and the covered benefit OON rule 
(jsonBathroomSDOON). If the benefit was covered in-network only, the x would have been inserted for 
the jsonBathroomSDOONnc rule (nc = not covered). 



CodySoft® Templates Reference and User Guide| 9 

© 2024 Cody Consulting Group, Inc.  All Rights Reserved. For internal use only. CONFIDENTIAL 

 

Cody EOC template POS Medical Benefits chart excerpt: 

Because the MBCRG has an x for jsonBathroomSD, the benefit’s row will appear in the PBP’s version. 
Because the rules grid also has an x for jsonBathroomSDOON, the OON cost-sharing content will also 
appear. If the PBP covered the benefit in-network only, the jsonBathroomSDOONnc content will appear.  

 

Note: If the plan bid’s PBP Report indicates the benefit is covered out-of-network, the MBCRG will 
include the x for the OON rule. If you want the benefit to show as covered in-network only, an edit to 
the MBCRG field within the PBP Module® Rules Grid Fields will be required. 
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2.3.3 CustomRG rules  
The following rules point to the Custom Rules Grid (CustomRG): 

1. The instruction rule contains CMS instructional language as well as CCG notes.  
2. The omit rule contains select content to be omitted from versions (e.g., non-applicable model 

content).  
3. The user-created rules contain variable content not addressed in other IF/ENDIF statements. 

CustomRG: 

 

Example: instruction rule for CMS model instruction. To display CMS instructions within the version, 
insert a lower-case x in the plan’s instruction rule cell of the CustomRG. 

[[IF:RuleId={CustomRGinstruction}]][Plans that meet the 5% alternative language 
threshold insert:] [[ENDIF:RuleId={CustomRGinstruction}]]   
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Example: omit rule for non-applicable model content. This bullet will not appear within any version 
generated from this template because it appears within the omit rule’s IF/ENIDIF statements and the 
CustomRG does NOT have an x for the omit rule. See CustomRG screenshot above. 
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3 Color Key 

Key: 
Red – content merged from data source (Benefits data grid; Companion grid) 
Green – variable content within AERG and MBCRG rules ( and CustomRG rules, if applicable) 
Orange – CMS-compliant language that is not part of the CMS model and is not within an IF/ENDIF 
statement. This content will appear in every version. 
Light blue – Cody edits to model 
Black – model content 
Yellow – attention required; CCG notes, instructions for required content, and sample content 
Aqua – attention required; CMS instructions for highly customizable language (e.g., Plans may modify…) 
Magenta – IF/ENDIF statements for AERG and MBCRG rules grids 
Blue – model instructions and IF/ENDIF statements for instruction and omit rules 
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4 Computer Settings (Cody-recommended) 

The following settings are recommended to help increase efficiencies while working with the Cody 
templates. 

4.1 Microsoft Word settings 

☐ File > Options > Display > Paragraph marks 

 

In the Home ribbon, the Show Paragraph icon is highlighted in gray. This setting allows you to view 
formatting symbols to help control how text is laid out within the document. You can identify extra 
spaces between words, where paragraphs end, page and section breaks, and more. 
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☐ File > Options > Proofing > AutoCorrect Options > AutoFormat As You Type 

Remove checkmarks from Automatic bulleted lists and Automatic numbered lists to prevent Word 
from automatically formatting a list. 

 

☐ File > Options > Advanced > When selecting, automatically select entire word 

Remove checkmark for easier selection of content. 
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☐ File > Options > Advanced > Show Bookmarks 
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4.2 Quick Access Toolbar 

The Quick Access Toolbar provides easy access to frequently used commands. 

Click on this link for instructions from Microsoft: Microsoft link. 

☐ File > Options > Quick Access Toolbar 

Recommended commands for your Quick Access Toolbar: 

 

Ribbon view of the highlighted commands: 

 

https://support.microsoft.com/en-us/office/customize-the-quick-access-toolbar-43fff1c9-ebc4-4963-bdbd-c2b6b0739e52#bkmk_show_hide_qat
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5 Word Styles 

The Cody ANOC and EOC templates are formatted with standardized Word styles. Instead of using direct 
formatting (e.g., using the Word ribbon to apply bolding), the use of styles help you maintain consistent 
formatting throughout the documents. They are also used for creating the Table of Contents and for 
displaying chapter and section names within the navigation pane. 

5.1 Copy-and-pasting 

IMPORTANT: When copying content from a source document, paste text ONLY. This will prevent 
overriding of existing styles within the template. 

1. Copy content from source document. 
2. Right-click on template location for insertion of content. 
3. In Paste Options, click Keep Text Only (T). 

 

5.2 Displaying styles pane 
In the Home ribbon, display the Styles pane by clicking the highlighted arrow. 

 

To dock the Styles pane, drag it to the right beyond the edge of the window. 
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5.3 Applying a Word style 

Place cursor anywhere in the paragraph and select the desired style from the Styles pane. In the 
example below, the sentence was changed from the Normal style (+ orange) to the List Bullet style (+ 
orange). Orange-colored text is CMS-compliant language that is not part of the CMS model and is not 
within an IF/ENDIF statement. This content will appear in every version. 
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5.4 Frequently used Word styles 

EOC styles: 
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EOC styles: 
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ANOC styles: 
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ANOC styles: 
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5.5 Changing the font 

Most Word Styles in the Cody ANOC and EOC templates are based on the Normal style which is 12 pt 
Times New Roman. Changing the font for this style will also change the font for other styles based on 
the Normal style.  

1. On the Styles pane, click the arrow to the right of the Normal style. (left image) 
2. On the pulldown menu, click Modify. (right image) 
3. Modify Style > Formatting > Select font from pulldown menu. (right image) 
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6 Word Tables 

The Cody templates include specific table formatting. 

6.1 Selecting a table 

☐ Click + to select entire table. 

 

6.2 Viewing gridlines 

☐ Click Borders > View Gridlines. This setting allows you to see the edges of each cell within columns 
and rows.  
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6.3 Table properties for inserting a new table 

Right-click on a table to select Table Properties. 

 

☐ Table Properties > Table Options > Options > Automatically resize to fit contents is deselected to 
ensure a table’s width remains intact. 

 

6.4 “Invisible” rows 

The ANOC template’s Medical Benefit Changes chart includes an “invisible” row for each benefit. 
Because changes to a benefit may vary from PBP to PBP, the addition of this row ensures the last row for 
the benefit will have a visible bottom border. This row appears above the benefit’s final ENDIF 
statement. The row is formatted with the MBC no space style and each cell includes a space; do NOT 
remove these spaces. The ENDIF row below this row is formatted with a top border.  
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Example in version: 
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The EOC template’s Chapter 4 Medical Benefits chart also includes “invisible” rows for some benefits. 
Because coverage for mandatory supplemental benefits may vary from PBP to PBP, the addition of this 
row ensures the last row for the benefit will have a visible bottom border. This “invisible” row appears 
after the benefit’s last variable row. The row is formatted with the Chart row no spacing style and each 
cell includes a space; do NOT remove these spaces. 

 

Example in version: 

 



CodySoft® Templates Reference and User Guide| 28 

© 2024 Cody Consulting Group, Inc.  All Rights Reserved. For internal use only. CONFIDENTIAL 

6.5 Inserting a variable row 

Variable rows require a separate row for placement of the rule’s IF statement. The IF statement is 
positioned in the rightmost column. All other cells within this row must be blank. 

The row(s) with the variable content have the ENDIF statement positioned in the rightmost column after 
or below any content in the cell. 

If the rule used for the variable row is new (i.e., does not exist in any of the standard Cody rules grids), 
add the new rule to the CustomRG rules grid. Remember to run the Rules Wizard after adding new 
rules. 

Example in template: 

Note placement of IF and ENDIF statements for the row. This row will appear within the version 
if the MBCRG has a lower-case x within the cell for the given plan. 

 

6.6 Removing a column 

Cody’s DSNP, HMO MAPD, and HMO MA EOC templates include a separate Chapter 4 Medical Benefits 
chart for plans with a POS option. The POS chart has out-of-network cost-sharing content in a separate 
column. To convert a three-column chart to a two-column chart (with both in-network and out-of-
network cost-sharing content within the same column), follow these steps. 
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1. At the top of the POS Medical Benefits Chart, right-click on What you must pay when you get 
these services and select Split Cells.  

 

 

After splitting this merged cell, its contents now appear in the middle column: 

 

2. Split cells for Emergency care, Urgently needed care, and Worldwide emergency and urgently 
needed care services rows.  

3. Review, cut and paste content from the rightmost column cell into the middle column cell for 
each benefit. Adjust, as needed. 



CodySoft® Templates Reference and User Guide| 30 

© 2024 Cody Consulting Group, Inc.  All Rights Reserved. For internal use only. CONFIDENTIAL 

Examples: 

OPTION A: Insert In-Network and Out-of-Network headers: 

 

OPTION B: Insert In-Network and Out-of-Network language: 
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4. For mandatory supplemental benefits, the IF statement must also be moved to the middle 
column. 

 

5. After all content has been removed from the rightmost column, delete the column. At the top of 
the POS Medical Benefits Chart, right-click in the rightmost cell and select Delete Cells > Delete 
entire column. 
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6. Right-click on the table and select Table Properties > Size > Preferred width change to 6.5 
inches and click OK. 

 

7. Select Services that are covered for you, then right-click to select Split Cells. 
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After splitting this merged cell, its contents now appear in two rows: 

 

8. Place cursor in the blank cell, then right-click and select Delete Cells > Delete entire row. 
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